MinMax Spaz

MinMax-Games.com

The water cooler of outer space
  
It is currently Fri 24 Nov, 2017 9:34 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: ATI 12.2 drivers checkup
PostPosted: Fri 09 Mar, 2012 11:33 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hi Guys,

I just got a post from a user who tried the new ATI drivers and reports that is causes stuttering. This of course is not something we want to impact the March 19th expansion release. Would it be possible if you have the time to try this new driver and let me know if it had caused problems with SPAZ? Only if you have an ATI card of course. I think it is probably the 69xx series of cards, but I want to make sure it isn't a wider issue.

http://support.amd.com/us/kbarticles/Pages/catalyst122precertifieddriver.aspx

Thanks very much,

Blorfy


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Fri 09 Mar, 2012 11:49 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Seems to work ok on my HD 5700 in OpenGL and DirectX, so I am less worried now, but a few more data points would be helpful for sure.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 7:50 pm 
Offline
Shortbus

Joined: Sat 10 Mar, 2012 7:45 pm
Posts: 5
Blorfy wrote:
Seems to work ok on my HD 5700 in OpenGL and DirectX, so I am less worried now, but a few more data points would be helpful for sure.


hey.
i just reinstal my windows.
also put my older ati 5000series.

its seems to give me same problem.
if i use older version it work corretly.

greating DarkEmpire.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:00 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm that is very strange. With your 5000 series, did you install the 12.2 driver?


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:07 pm 
Offline
Shortbus

Joined: Sat 10 Mar, 2012 7:45 pm
Posts: 5
Blorfy wrote:
Hmm that is very strange. With your 5000 series, did you install the 12.2 driver?



i just funt someting..
it my CCC, it give info that i have version.12.3
and on website that i have download (ati) website it give me 12.2

here more info

Direct3D-versie 7.14.10.0894
OpenGL-versie 6.14.10.11554
Versie Catalyst Control Center 2012.0214.2218.39913


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:09 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm that is interesting, so are you saying the problem is with the 12.3 drivers?


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:14 pm 
Offline
Shortbus

Joined: Sat 10 Mar, 2012 7:45 pm
Posts: 5
Blorfy wrote:
Hmm that is interesting, so are you saying the problem is with the 12.3 drivers?


yes.

but i dont understand why website say version 12.2..


Eddit: i just font this.
http://forums.adobe.com/message/4253915


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:33 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Hmm really odd. It seems like the release needs some oversight still. If directX mode is working properly, I would just use that for now as the backup. Thanks for the report. I will have to follow this up more next week.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:42 pm 
Offline
Hound
User avatar

Joined: Sun 12 Feb, 2012 8:27 pm
Posts: 1058
As long as we get the update, fine by me. That'll give at least new material for the bug report forum.

_________________
What makes me a good Specialist?
Well, if i was a bad Specialist, I wouldn't be sitting here, discussing it with you, now would I?

Professional Vanquisher of bots
+100% Banpower


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 10 Mar, 2012 8:47 pm 
Offline
Shortbus

Joined: Sat 10 Mar, 2012 7:45 pm
Posts: 5
Blorfy wrote:
Hmm really odd. It seems like the release needs some oversight still. If directX mode is working properly, I would just use that for now as the backup. Thanks for the report. I will have to follow this up more next week.




No problem :)
here to help.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 14 Mar, 2012 4:27 am 
Offline
Shortbus
User avatar

Joined: Wed 14 Mar, 2012 4:20 am
Posts: 2
I can confirm the stuttering with my 6950. I just downloaded the demo to give the game a try and it's unplayable. Thought it was a problem with my overclock, glad to hear it's just a driver problem. Guess I'll just wait for the next driver release, don't feel like downgrading to an older driver.

darkempire100 wrote:
i just funt someting..
it my CCC, it give info that i have version.12.3
and on website that i have download (ati) website it give me 12.2


That's normal. They called it 12.3 since they released them a little late and the release ended up in March instead of February.

_________________
Image


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 14 Mar, 2012 5:43 am 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Thanks for the second look. It "should" be playable in directX mode if you give that a try. It is bottom left in the launcher.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 14 Mar, 2012 6:27 am 
Offline
Shortbus
User avatar

Joined: Wed 14 Mar, 2012 4:20 am
Posts: 2
Blorfy wrote:
Thanks for the second look. It "should" be playable in directX mode if you give that a try. It is bottom left in the launcher.

I tried that before but never thought to actually try clicking on "continue" to launch the game. :o

So yeah, it's working now. Time for me to try the demo! Oh, and I read your story on the Steam forums. Pretty cool stuff. :)

_________________
Image


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 14 Mar, 2012 6:50 am 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Ahh, glad it is working for you. Enjoy the demo. There is a free expansion coming out March 19th. You may want to wait to purchase till then. We are trying to put the game on sale that day. Doing our best to make it happen.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Mon 19 Mar, 2012 4:15 pm 
Offline
Shortbus
User avatar

Joined: Mon 19 Mar, 2012 4:03 pm
Posts: 1
I just started up SPAZ and gave it a quick test, and i am not having any problems. Everything is running smothly on my machine. The only thing that you can do now is wait and hope. Sorry if this isn't that helpful.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Mon 19 Mar, 2012 5:38 pm 
Offline
Shortbus

Joined: Mon 19 Mar, 2012 5:35 pm
Posts: 4
Hey all.
I can confirm i have this issue on my 4870x2 and the 12.2 driver.
Problem came after i updated my driver. DirectX compatible mode works.

Greets from Norway and eagerly waiting for the Bountyhunter release.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Mon 19 Mar, 2012 7:41 pm 
Offline
Scout

Joined: Thu 31 Mar, 2011 9:55 pm
Posts: 36
Hey,

my SPAZ is stuttering when i try to play it with the ati driver version 12.3.

I have a ATI Radeon HD 4800 Series card and use a Win 7 64bit OS.

The DirectX compatibility mode is working fine for me. Gone fight some bounty hunters now ;)

_________________
RayBeans @ Steam, admin of the inofficial SPAZ group
http://steamcommunity.com/groups/SpaPiZo


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Mon 19 Mar, 2012 9:03 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Yeah, we will have to talk to ATI. Hopefully we can get through to someone who can help.

Luckily DX mode works.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Tue 20 Mar, 2012 4:06 pm 
Offline
Shortbus

Joined: Tue 20 Mar, 2012 4:03 pm
Posts: 1
I can confirm that this happens with the ATI 4xxx series(catalyst 12.2) as well, DX mode fixes it. Worked fine before.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Tue 20 Mar, 2012 6:58 pm 
Offline
Shortbus
User avatar

Joined: Thu 12 May, 2011 7:44 pm
Posts: 7
I had this issue, for whatever reason SPAZ's affinity was set to only CPU0. When I set it to use all of the cores the stuttering went away.

ATI 4850 driver12.2

Fraps reported 30fps with only CPU0 but it was stuttering badly. After enabling all of the other cores it jumped up to 60+ with no stuttering.

No need to restart the game when screwing with the affinity.

Don't mess with the priority level though.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 21 Mar, 2012 2:28 am 
Offline
Shortbus

Joined: Tue 31 May, 2011 1:48 pm
Posts: 2
Yep. ATI 12.2 with HD6970. Without directx enabled the game is unplayable.


But such events like this is expected if you are long time ATI users anyway.... Their OpenGL support is really sub-par.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 21 Mar, 2012 2:34 pm 
Offline
Shortbus

Joined: Mon 19 Mar, 2012 5:35 pm
Posts: 4
codefeenix fix does the job.

Fire upp the Laucher. hit CTRL+SHIFT+ESC to get Tastkmanager->find Spazgame.exe*32->Rightclick on mouse->set Affinity->Set mark in <all processors>hit ok and you are done. Launch as normal.
Remember to turn Directx mode off.
Looks like you have to do this everytime you start Spaz. Maybe someone know a way to set this a default?
Looks like you can just use 2 cores, no need for all of them. 0 and 1 together works fine here.


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Wed 21 Mar, 2012 9:02 pm 
Offline
Scout

Joined: Thu 31 Mar, 2011 9:55 pm
Posts: 36
Cyclops25 wrote:
codefeenix fix does the job.

Fire upp the Laucher. hit CTRL+SHIFT+ESC to get Tastkmanager->find Spazgame.exe*32->Rightclick on mouse->set Affinity->Set mark in <all processors>hit ok and you are done. Launch as normal.
Remember to turn Directx mode off.
Looks like you have to do this everytime you start Spaz. Maybe someone know a way to set this a default?
Looks like you can just use 2 cores, no need for all of them. 0 and 1 together works fine here.



Thanks for this workaround. Just wanted to confirm that this works for me. :) @devs If you should need any data/logs from me just send me a pm or post here.

_________________
RayBeans @ Steam, admin of the inofficial SPAZ group
http://steamcommunity.com/groups/SpaPiZo


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sat 24 Mar, 2012 8:01 pm 
Offline
Shortbus

Joined: Sat 27 Aug, 2011 9:55 pm
Posts: 8
Yup, setting CPU affinity fixed it for me. Thans a lot! :)


Top
 Profile  
 
 Post subject: Re: ATI 12.2 drivers checkup
PostPosted: Sun 25 Mar, 2012 7:55 am 
Offline
Shortbus

Joined: Mon 19 Mar, 2012 9:38 pm
Posts: 4
cpu affinity fixed it for me as well... odd that it would default to only 1 core


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 43 posts ]  Go to page 1, 2  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group