MinMax Spaz

MinMax-Games.com

The water cooler of outer space
  
It is currently Tue 23 Jan, 2018 1:23 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Game runs at 30-ish FPS on Radeon 480
PostPosted: Tue 26 Sep, 2017 7:33 pm 
Offline
Shortbus

Joined: Tue 26 Sep, 2017 4:42 pm
Posts: 2
Heya

I have some issues with severe slowdowns affecting the enjoyment of the game, which otherwise is very nice.

My specs are:
PowerColor Radeon RX 480 Devil 8192MB
Intel Core i7 6700K
ASUS Z170 PRO GAMING DDR4
Corsair Vengeance LPX - 2x8GB DDR4 3000MHz PC4-24000 CL15

Dxdiag uploaded as well.

I have made some graphs with MSI Afterburner.

Here is the menu, default high settings:

Image

Here is a battle with 4 motherships, default high settings:

Image

Here is me destroying asteroids after the battle:

Image

Here is the same battle on default medium:

Image

And on low:

Image

Here is me running around in Witcher 3 in Toussaint on Ultra with hairworks off:

Image

The only slowdowns were some weirdness were the GPU clock fell, so was likely a driver issue.

Witcher 3 on ultra is perfectly playable, but SPAZ2 on low is a stuttering mess?!

Here is me doing the SPAZ2 space battle again, with the graphs for all 8 logical CPUs as well as my FPS:

Image


Attachments:
DxDiag.txt [79.22 KiB]
Downloaded 12 times
Top
 Profile  
 
 Post subject: Re: Game runs at 30-ish FPS on Radeon 480
PostPosted: Tue 26 Sep, 2017 11:18 pm 
Offline
Shortbus

Joined: Tue 26 Sep, 2017 4:42 pm
Posts: 2
UPDATE:

ISSUE FIXED.

I googled around and turns out that Unity has a dislike for the combination of Freesync and Window Borderless. It doesn't happen to everybody, and even then it doesn't happen for every game. As SPAZ2, like most Unity games, runs in Windowed borderless, it conflicted with Freesync causing the issue.

I initally confirmed it to be working by forcing exclusive full-screen using -window-mode exclusive as a shortcut command. This allows Freesync to work properly.

Disabling Freesync in software does not fix the issue.

I then tried to force enable Vsync from the Radeon settings, which causes a crash upon loading the map. This would however disable Freesync, so would have worked in theory. If done for SPAZ2 specifically, it crashes. If done globally, it just does nothing.

Disabling Freesync on the monitor works too. This also fixes the stuttering and makes the game buttersmooth.

In case it is an issue with the specific monitor / adaptive sync module, here is the monitor I use:
ViewSonic XG2401 24-inch
Model number: VS16265
Serial number: UG2161100257

Hopefully this is a bug that can be fixed, because it sucks having to either fiddle with their monitors to disable Freesync or using shortcut commands that are glitchy in order to enjoy the game in an actually playable state.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group