MinMax Spaz

MinMax-Games.com

The water cooler of outer space
  
It is currently Tue 12 Dec, 2017 7:05 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: nVidia GTX680 and SPAZ; terrible performance (& workaround)
PostPosted: Sat 05 May, 2012 5:01 pm 
Offline
Shortbus
User avatar

Joined: Sat 05 May, 2012 4:34 pm
Posts: 3
Joined to post about an issue I've just discovered with SPAZ on a GTX680 running the launch (301.10) drivers. I've been playing SPAZ on various computers (via my Steam copy, in case anyone cares) and this is literally the first time I've had an issue with it in any way, shape or form. It's been much better behaved than many of the (supposedly?) 'AAA' titles that I've played in recent years. So, props to the developers for that.

But I digress...

The issue... SPAZ (v1.600) runs terribly on a GTX680 (rest of the system is; Core i7 920 @ 3.8GHz, 24GB RAM, SSD). The game defaults to OpenGL (fine, no problem...) but runs at 14-15fps (as recorded by MSI Afterburner) with GPU utilisation basically idle... never going above 2% (Foobar 2000 visualisations work the GPU harder than that!)... every other game I've tried since getting the 680 works as expected.

I found this thread about an AMD driver issue more by luck than by judgement, as it shares a similar issue for me - the GPU is recognised as VEN_0000 and DEV_0000 as recorded in the log. I did think about trying the beta 301.24 drivers, but I tend to be a bit allergic to nVidia beta drivers as they've bitten me in the past.

Setting affinity did nothing to help. DirectX Compatibility mode really, really broke the game. It ran faster, but colours were all over the place and the cursor just wasn't rendering.

A workaround is run the game Windowed, sacrificing fullscreen. With that, I get a stable 60fps (adaptive Vsync on) and GPU utilisation is up at more reasonable levels.

For now, the workaround will let me game. But if the devs have got any other suggestions or possible fixes, 'twould be good.

...

I'm going to go back to playing with the modkit now... :D

edit: Spelling error

_________________
Ex nilhilo nihil fit


Top
 Profile  
 
 Post subject: Re: nVidia GTX680 and SPAZ; terrible performance (& workarou
PostPosted: Sat 05 May, 2012 5:13 pm 
Offline
Developer
User avatar

Joined: Fri 25 Feb, 2011 3:39 am
Posts: 1767
Wow, thanks very much for this detailed writeup. I received a mail from a user about the ven_000 issue and it is something within the engine, but it looks like it can be fixed. This "may" resolve your issue. Once I get that fix in, I would like to contact you to test it if that would be ok?


Top
 Profile  
 
 Post subject: Re: nVidia GTX680 and SPAZ; terrible performance (& workarou
PostPosted: Sat 05 May, 2012 7:14 pm 
Offline
Hound
User avatar

Joined: Thu 15 Sep, 2011 3:54 am
Posts: 1400
You might also try fiddling around with the Nvidia Control Panel.


Top
 Profile  
 
 Post subject: Re: nVidia GTX680 and SPAZ; terrible performance (& workarou
PostPosted: Sat 05 May, 2012 8:50 pm 
Offline
Shortbus
User avatar

Joined: Sat 05 May, 2012 4:34 pm
Posts: 3
Blorfy wrote:
Wow, thanks very much for this detailed writeup. I received a mail from a user about the ven_000 issue and it is something within the engine, but it looks like it can be fixed. This "may" resolve your issue. Once I get that fix in, I would like to contact you to test it if that would be ok?

Yes, that would be fine; happy to help. :) I'm presuming that the forum gives you access to the e-mail I signed up with?

Palandus wrote:
You might also try fiddling around with the Nvidia Control Panel.

Tried that, too, although no tweaks in there made any difference. :(

_________________
Ex nilhilo nihil fit


Top
 Profile  
 
 Post subject: Re: nVidia GTX680 and SPAZ; terrible performance (& workarou
PostPosted: Sun 06 May, 2012 6:38 am 
Offline
Volley
User avatar

Joined: Sat 05 May, 2012 11:24 am
Posts: 569
I too seem to have the same issue. I however noticed the drop in FPS since a few patches ago(around when the Christmas mod came out). I had to disable show clouds and lower the effects and debris slide bars to keep the same performance.

Code:
Reading Display Device information...
   Primary Display Device Found:
      Vendor Id: VEN_0000
      Device Id: DEV_0000

my gfx card is GeForce 9600 GT.
It switches over to OpenGL but, it seems to be slower when in that mode.

To be fair I am using an older version of the drivers... 258.96 but, like I said the drop in performance was around when the Christmas mod came out. I will see if updating the drivers will fix the problem.

edit:

so I updated to the latest nvidia drivers and still getting detection issues...

OpenGL still detects the same as before.
Code:
OpenGL driver information:
  Vendor: NVIDIA Corporation
  Renderer: GeForce 9600 GT/PCIe/SSE2
  Version: 3.3.0


doing the affinity trick works good too.

_________________
Image
I can owns most spam threads? viewtopic.php?f=5&t=3264


Top
 Profile  
 
 Post subject: Re: nVidia GTX680 and SPAZ; terrible performance (& workarou
PostPosted: Tue 08 May, 2012 8:22 pm 
Offline
Shortbus
User avatar

Joined: Sat 05 May, 2012 4:34 pm
Posts: 3
Further to viromans' post, I did some more investigating of my own, as I don't (didn't) experience the same issues he does with 258.96.

258.96 were the first nVidia drivers to support "Surround" (triple monitor gaming) that weren't beta - and the only ones that worked for me without issues for months after I started gaming in Surround. While I wasn't playing SPAZ in Surround, it played without issues on 258.96 and 295.something-or-other... unfortunately, I sold those cards to fund my GTX680, so I can't go back and check what they were reporting as in consolelog. If I get time before you find the fix, Blorfy, I can try it out on a 470SLI system that plays SPAZ perfectly to report back on whether that sees the cards correctly or not...

_________________
Ex nilhilo nihil fit


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group